Reverse Engineering Team
Unregistered, You must accept the Forum Rules below to be able to use some forum functions.

Read forum rules below...

1. All posts must be written in English.
2. Don't spam/abuse any other member via E-mail or Private Messages.
3. Have phun!

For breaking above rules you may be warned/banned appropriately!

Problem with emulating HASP HL (purple)

View previous topic View next topic Go down

Problem with emulating HASP HL (purple)

Post by markownik on Wed Jun 12, 2013 3:21 pm

Hey, I'm as new to this forum as to the subject of dongle security Razz But I think I'm able to learn fast. I've searched for many solutions and this is what I came into:
 - I used haSploGer.exe to get pass1, pass2 and saved some logs.
 - I've dumped the dongle with h5dmp.exe using passwords.
 - Using UniDumpToReg I created reg file to install into registry
 - In that reg file I've changed the first 'location' line to match Multikey requirements. 
 - I've added "DongleType"=dword:00000001 line.
 - I've installed that file in registry.
 - I have run the install.cmd from multikey.
The service starts properly and dongle looks connected in device manager, however it is not recognised by the hasp service (driver is ver 5.95) on localhost:1947.
May it be that the software which usues the dongle is SRM api protected? The software doesn't detect the emulated dongle (the 00007 error). Everything is tried to be done on Windows XP 32-bit SP3.
Any help would be greatly appreciated Smile

markownik

Posts : 4
Points : 6
Reputation : 0
Join date : 2013-06-12

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by hasp on Wed Jun 12, 2013 9:49 pm

H007 error mean missing qa tables.
Show your log and target soft link

hasp

Posts : 444
Points : 599
Reputation : 147
Join date : 2011-12-16

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by markownik on Thu Jun 13, 2013 1:41 am

log is here: pastebin,com/Y0iD3T8i
target software install here: mh96cd.1fichier,com
their homepage: www,qwed,eu
my dump files: 5zu0b8.1fichier,com

I'm too fresh to post external links, so change the comma to dot in links Smile

markownik

Posts : 4
Points : 6
Reputation : 0
Join date : 2013-06-12

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by prenumele on Thu Jun 13, 2013 7:23 am

hasp_windows_45772.dll  seems to be also srm

prenumele

Posts : 135
Points : 179
Reputation : 30
Join date : 2010-09-11

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by bobpj on Fri Jun 14, 2013 6:18 pm

Hi where did you get the instructions how how to dump purple hasp key?  I am currently trying to do it and need the files. I got the sentinel key I have working with multikey just havent been able to use the dmp file from HASPHL2010 with any reg converter... 

Thanks

bobpj

Posts : 7
Points : 11
Reputation : 0
Join date : 2013-05-01

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by markownik on Fri Jun 14, 2013 6:49 pm

@bobpj - Here you go, the tools and the instruction in html (I had problems with toro so you could do it way I described). link: k3jrne,1fichier,com

going back to topic:
I have investigated older version of the target software which uses standard 5.2 hasp hl driver and it runs fine on key dump I made Smile so I'm sure that I have SRM protected software. Razz Now, I have even more questions:
 - What tools should I use to dump such dongle?
I've read that usually USBTracer and SRM2Mult_1.2 are needed, I've also read about using HaspSrmDumper1.5...
 - And after all, even if I succeed to dump it, what should I do next?
There are none publicly and free emulators avalible, what more they are not universal... Could you give me more hints? Razz I really want to learn it Smile

markownik

Posts : 4
Points : 6
Reputation : 0
Join date : 2013-06-12

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by nodongle.biz on Sat Jun 15, 2013 12:53 am

@markownik
The protected software contains many enveloped files.
For prepare the emulator you need make usbtrace logs.

nodongle.biz

Posts : 308
Points : 359
Reputation : 26
Join date : 2013-05-16
Location : nodongle.biz

http://nodongle.biz

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by markownik on Sat Jun 15, 2013 4:21 pm

OK, I'm going to make these dumps & logs as soon as I can, I would say: before wednesday Smile

edit || 19.VI.2013 11:27 - hey, I will have the dumps and logs needed next week, sorry for delay but it's not because of me :/

markownik

Posts : 4
Points : 6
Reputation : 0
Join date : 2013-06-12

Back to top Go down

Re: Problem with emulating HASP HL (purple)

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum